vue.js 版本过高所带来的问题——1

原创 奔跑的小前端 随笔 待整理 335阅读 2017-11-30 11:34:35 举报

前天不小心npm update 了,所以把自己原本项目的vue和vuex 版本都升级了,所带来的问题是:

Uncaught TypeError: Cannot read property 'dispatch' of undefined vue

一开始我以为项目没有声明注册,然后发现有声明注册,后来跟同事说了一下,有可能是版本过高的问题,当我把版本降低后,随之而来的问题也解决了。
看来有时间不能乱升级版本啊~~

评论 ( 2 )
最新评论
奔跑的小前端 1F 2017-11-30 15:49:39 2F

兄弟,我没有这么认真看官方文档,不过你说了,倒也提醒了我。

人马在冬至追风 2017-11-30 13:05:04 1F

啥啊 vue2.0废除了$dispatch的方法 跟你项目注不注册有啥关系