React技术栈搭建IE8开发环境

由于项目需求,需要兼容IE8,而目前又没有找到符合预期的轮子,于是自己手撸了一个

技术栈

  • react react@0.14.9 15以上版本不兼容IE
  • react-router@2.3.0 2.4以上不支持IE8
  • rematch 状态管理,redux的替代者,当然这里使用redux也可以,mobx@4.x经测试在IE8中不可用
  • axios网络请求库,fly.js经测试在IE8中不可用
  • webpack@1.15.0
  • antd@1.11.6 UI框架,2以上不支持IE8
  • echarts@4.1 IE8兼容基础图表,也可以去官网定制兼容IE8图表

GitHub模板地址

评论 ( 0 )
最新评论
暂无评论

赶紧努力消灭 0 回复