ie8兼容问题

转载 (原文地址) jin123 随笔 兼容 99阅读 2018-09-25 15:43:02 举报

react兼容ie8

(https://github.com/xcatliu/react-ie8)
  一、按照官方微博的公布信息,支持ie8的最高版本是react@0.14版本,如果高于这个版本则是不兼容IE8的,所以得确定你使用的react版本不高于0.14。根据官方的说法,兼容的方法只需要在index.html中引入es5-shim.js和es5-sham.js(可以通过百度 搜索下载)这两个文件就行,这两个文件是一个将es5语法修改兼容es3语法的polyfill,但在项目实际添加了这两个文件后,还是会报一些错误。

     二、确保使用的Jquery版本是1.x.x的版本,IE8不支持Juqery2.x的版本。如果你使用了BootStrap框架,这个框架需要最低的Jquery版本是1.9以上。

     三、对于另外两个框架 ,我使用的是"react-redux": "^4.4.1","react-router": "^1.0.3"。

     四、需要在package.json中加入以下的几个依赖包:

     "console-polyfill": "^0.2.2",
    "es5-shim": "^4.4.1",
    "eventsource-polyfill": "^0.9.6",
    "fetch-ie8": "^1.4.0",

   "babel-polyfill": "^6.7.4",

     加入以上几个依赖包后,在自己的前端程序入口的地方,把上面的几个安装包引入程序当中:

require('es5-shim');
require('es5-shim/es5-sham');
require('console-polyfill');
require('fetch-ie8');
require('babel-polyfill');

    五、以上的步骤完成后,ie8还是会报错,主要是Object.defineProperty函数相关的错误。这个时候需要一个关键的步骤在package.json中加入

        "es3ify-loader": "^0.2.0",

         这是一个将es5、es6语法转换成es3语法的包,这个包不需要在代码中引入到程序中,而是当我们的APP.js打包完成后,再使用这个loader进行再次的打包,我的app.js是采用gulp打包的,但es3ify-loader 只能用webpack打包工具

来进行调用,所以需要在项目目录安装webpack,输入命令:npm install -g webpack。同时在目录下创建webpack.config.js,里面内容是:

var webpack = require('webpack');
 
module.exports = {
    //页面入口文件配置,这里是用gulp打包出来的app.js
    entry: {
        index : './build/app.js'
    },
    //入口文件输出配置,这里需要设置对app.js打包后得到的文件名称
    output: {
        path: './',
        filename: 'bundle.js'
    },
    module: {
        //加载器配置,这里使用es3ify-loader对app.js进行再次打包;
        loaders: [
             {
                test: /.js?$/,
                loaders: ['es3ify-loader'],
             },
        ]
    },
};

以上步骤完成后,在项目目录下输入命令:webpack  则会自动开始打包,打包后本级目录下会生成bundle.js;

六、完成上述步骤后,就完成了React+Redux+Ruoter框架在IE8下的兼容性修改。这是我的完整修改过程,修改完成后程序顺利在IE8下运行起来了,由于整个前端编写的是一个单页应用,在IE8下页面切换刷新还是比较慢的。


本文来自 lycIT 的CSDN 博客 ,全文地址请点击:(https://blog.csdn.net/lycIT/article/details/79668945?utm_source=copy )

一句话解决IE兼容问题
<meta http-equiv="X-UA-Compatible" content="IE=7">

以上代码告诉IE浏览器,无论是否用DTD声明文档标准,IE8/9都会以IE7引擎来渲染页面。

<meta http-equiv="X-UA-Compatible" content="IE=8">

以上代码告诉IE浏览器,IE8/9都会以IE8引擎来渲染页面。

<meta http-equiv="X-UA-Compatible" content="IE=edge">

以上代码告诉IE浏览器,IE8/9及以后的版本都会以最高版本IE来渲染页面。

<meta http-equiv="X-UA-Compatible" content="IE=7,IE=9">
<meta http-equiv="X-UA-Compatible" content="IE=7,9">
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1">

以上代码IE=edge告诉IE使用最新的引擎渲染网页,chrome=1则可以激活Chrome Frame


本文来自 一木青 的CSDN 博客 ,全文地址请点击:https://blog.csdn.net/yimuqing123/article/details/53012549?utm_source=copy

评论 ( 0 )
最新评论
暂无评论

赶紧努力消灭 0 回复